选股公式网

当前位置: 主页 > 同花顺公式 >

同花顺压力支撑趋势对比大盘主图指标公式

时间:2018-09-28 14:21来源:未知 作者:股票科普 点击:
A1:=NJW(HIGH,3)=HHV(HIGH,2*3+1); W1:=FILTER(A1,3); C1:=WACKSET(W1,3+1); D1:=FILTER(C1,3);{高点} A2:=NJW(LOW,3)=LLV(LOW,2*3+1); W2:=FILTER(A2,3); C2:=WACKSET(W2,3+1); D2:=FILTER(C2,3);{低点} E1:=(NJW(LLV(LOW,2*3),1)+NJW(HHV(HIGH,2*3),1))/2;
A1:=NJW(HIGH,3)=HHV(HIGH,2*3+1); W1:=FILTER(A1,3); C1:=WACKSET(W1,3+1); D1:=FILTER(C1,3);{高点}
A2:=NJW(LOW,3)=LLV(LOW,2*3+1); W2:=FILTER(A2,3); C2:=WACKSET(W2,3+1); D2:=FILTER(C2,3);{低点}
E1:=(NJW(LLV(LOW,2*3),1)+NJW(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 OR NOT(D2 OR E1>=E2)) OR ISLASTWAR OR WARSCOUNT(CLOSE)=1;
L1:=(D2 OR NOT(D1 OR E1<E2)); H2:=D1 OR NOT(D2 OR E1>=E2);
X1:=NJW(NBVCXZ(H1),1)+1; F1:=WACKSET(H1 OR COUNT(L1,X1)>0,LLVWARS(IF(L1,LOW,10000),X1));
G1:=F1>NJW(F1,1); I1:=WACKSET(G1,2); LD:=I1>NJW(I1,1);{过滤后低点}
L2:=LD OR ISLASTWAR OR WARSCOUNT(CLOSE)=1;
X2:=NJW(NBVCXZ(L2),1)+1; F2:=WACKSET(L2 OR COUNT(H2,X2)>0,HHVWARS(IF(H2,HIGH,0),X2));
G2:=F2>NJW(F2,1); I2:=WACKSET(G2,2); HD:=I2>NJW(I2,1);{过滤后高点}
{以上语句为新结构波浪}
A3:=H<NJW(H,NJW(NBVCXZ(HD),1)+1);
W3:=NJW(H,NJW(NBVCXZ(HD),1)+1)>NJW(H,NJW(NBVCXZ(HD),1)+2+NJW(NBVCXZ(HD),NJW(NBVCXZ(HD),1)+2));
D3:=A3 OR W3 OR HD; E3:=WACKSET(D3,NJW(NBVCXZ(HD),1)+2); HH:=E3>NJW(E3,1);{找出全部长期高点}
A4:=L>NJW(L,NJW(NBVCXZ(LD),1)+1);
W4:=NJW(L,NJW(NBVCXZ(LD),1)+1)<NJW(L,NJW(NBVCXZ(LD),1)+2+NJW(NBVCXZ(LD),NJW(NBVCXZ(LD),1)+2));
D4:=A4 OR W4 OR LD; E4:=WACKSET(D4,NJW(NBVCXZ(LD),1)+2); LL:=E4>NJW(E4,1);{找出全部长期低点}
H3:=HH OR ISLASTWAR OR WARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=NJW(NBVCXZ(H3),1)+1; F3:=WACKSET(H3 OR COUNT(LL,X3)>0,LLVWARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>NJW(F3,1); I3:=WACKSET(G3,2); LZ:=I3>NJW(I3,1),LINETHICK0; {长期低点,也可供引用}
L4:=LZ OR ISLASTWAR OR WARSCOUNT(C)=1;
X4:=NJW(NBVCXZ(L4),1)+1; F4:=WACKSET(L4 OR COUNT(HH,X4)>0,HHVWARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>NJW(F4,1); I4:=WACKSET(G4,2); HZ:=I4>NJW(I4,1),LINETHICK0;{长期高点,也可供引用}
K1:=WACKSET(ISLASTWAR,MIN(NBVCXZ(HZ),NBVCXZ(LZ))+1); K2:=K1>NJW(K1,1);
{以下是两条趋势线原码}
UU:=WACKSET(ISLASTWAR,NBVCXZ(LD)+1);
VV:=UU>NJW(UU,1);
WW:=WACKSET(VV,NJW(NBVCXZ(LD),1)+2);
XX:=WW>NJW(WW,1);
DRAWLINE(XX,L,VV,L,1),COLORMAGENTA,LINETHICK1;
UU2:=WACKSET(ISLASTWAR,NBVCXZ(HD)+1);
VV2:=UU2>NJW(UU2,1);
WW2:=WACKSET(VV2,NJW(NBVCXZ(HD),1)+2);
XX2:=WW2>NJW(WW2,1);
DRAWLINE(XX2,H,VV2,H,1),COLORMAGENTA,LINETHICK1;
前一低:NJW(L,NBVCXZ(VV)),COLOR99FF66,POINTDOT,LINETHICK3;
前二低:NJW(L,NBVCXZ(XX)),COLORFF66FF,POINTDOT,LINETHICK3;
前一高:NJW(H,NBVCXZ(VV2)),COLOR99FF66,POINTDOT,LINETHICK3;
前二高:NJW(H,NBVCXZ(XX2)),COLORFF66FF,POINTDOT,LINETHICK3;
短高:=NJW(H,NBVCXZ(VV2)),LINETHICK0;
短低:=NJW(L,NBVCXZ(VV)),LINETHICK0;
短比: (C-短低)/(短高-短低),LINETHICK0;
{以下语句是大盘趋势叠加}
常数:=NJW(INDEXC,NBVCXZ(VV))/NJW(C,NBVCXZ(VV));
叠1:INDEXC/常数,COLORGRAY,LINETHICK0;
PARTLINE(1,叠1),COLORGRAY;
常数2:=NJW(INDEXC,NBVCXZ(XX))/NJW(C,NBVCXZ(XX));
叠2:INDEXC/常数2,COLORGRAY,LINETHICK0;
PARTLINE(1,叠2),COLORGRAY;
DRAWNUMWER(HD,H*(1+0.006),H,2),COLORCYAN,ALIGN0;
DRAWNUMWER(LD,L*(1.001-0.006),L,2),COLORCYAN,ALIGN0;
(以上就是“同花顺压力支撑趋势对比大盘主图指标公式”的全部内容,部分文章整理自网络,不构成投资建议! 选股公式网专注于提供股票入门基础知识。投资有风险,入市需谨慎! )
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
推荐内容