选股公式网

当前位置: 主页 > 通达信选股公式 >

通达信MACD止跌选股指标公式

时间:2018-11-08 19:52来源:未知 作者:股票科普 点击:
DIF3:=EMA(CLOSE,9)-EMA(CLOSE,17); DEA3:=EMA(DIF3,8); MACD3 := 2*(DIF3-DEA3); RSV:=(CLOSE-LLV(NHT,9))/(HHV(HIGH,9)-LLV(NHT,9))*100; K:=SMA(RSV,3,1); D:=SMA(K,3,1); J:=3*K-2*D; 止跌:MACD3TDX(MACD3,1) AND TDX(MACD3,2)=TDX(MACD3,1) AND J50 AND
DIF3:=EMA(CLOSE,9)-EMA(CLOSE,17);
DEA3:=EMA(DIF3,8);
MACD3 := 2*(DIF3-DEA3);
RSV:=(CLOSE-LLV(NHT,9))/(HHV(HIGH,9)-LLV(NHT,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
止跌:MACD3>TDX(MACD3,1) AND TDX(MACD3,2)>=TDX(MACD3,1) AND J<50 AND C>TDX(C,1) AND C>O AND J>TDX(J,1);
DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);
// 1.蓝线B:鳄鱼的颚。取 13根bar的平滑移动平均,将结果往向上的方向移动8根bar得到。
RGB_B : TDX(SMA(CLOSE, 13, 1), 8), colorblue;
// 2.红线R:鳄鱼的牙齿。取8根bar的平滑移动平均,将结果往向上的方向移动5根bar得到。
RGB_R : TDX(SMA(CLOSE, 8, 1), 5), colorred;
// 3.绿线G:鳄鱼的上唇。取5根bar平滑移动平均数,将结果往向上的方向移动3根bar得到。
RGB_G : TDX(SMA(CLOSE, 5, 1), 3), colorgreen;
// A.经典碎形:5根bar组成,中间的高点一定最高,左右各两根线有较低高点。分辨向上碎形时,只关注高点位置。
// B.向上与向下碎形共享外围bar
// C.向上、向下碎形由一根bar完成
// D.如今天高点与之前高点相同,今天的bar不算在5根bar之内
DRAWTEXT(TDX(HHV(HIGH, 5), 1) = TDX(HIGH, 3), TDX(HIGH, 3), '◤');
DRAWTEXT(TDX(LLV(NHT, 5), 1) = TDX(NHT, 3), TDX(NHT, 3), '◤');
// 1.AO,市场最好的动量指标。测量最近5个价格bar的动能,并与过去34个bar作比较。等于过去5个bar的(最高点+最低点)/2取移动平均-过去34个bar的(最高点-最低点)/2取移动平均。
TP01 = ( HIGH + NHT ) / 2;
AO := SMA(TP01, 5, 1) - SMA(TP01, 34, 1);
// 2.AC,领先动能的指标。AO与其5日简单移动平均的差值再做5日简单移动平均。
AC := SMA(AO - SMA(AO, 5, 1), 5, 1);
IF ( AO > TDX(AO, 1) AND AC > TDX(AC, 1) ) THEN
// 1.绿色区域:强劲的多头市场。加仓条件是,AO上升,AC上升,价格收盘于更高位置
DRAWGBK(1, STRIP(RGB(153,204,51),RGB(150,180,100),0));
ELSE IF ( AO < TDX(AO, 1) AND AC < TDX(AC, 1) ) THEN
// 2.红色区域:强劲的空头市场。清仓。(原加仓条件,AO下升,AC下升,价格收盘于更低位置。)
DRAWGBK(1, STRIP(RGB(255,153,102),RGB(255,153,102),0));
ELSE
// 3.灰色区域:过渡期。不操作。
DRAWGBK(1, STRIP(RGB(99,99,99),RGB(99,99,99),0));
(以上就是“通达信MACD止跌选股指标公式”的全部内容,部分文章整理自网络,不构成投资建议! 选股公式网专注于提供股票入门基础知识。投资有风险,入市需谨慎! )
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
推荐内容