选股公式网

当前位置: 主页 > 通达信选股公式 >

通达信测量趋势强度指标公式

时间:2018-10-09 13:03来源:未知 作者:股票科普 点击:
ATR := NJT(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),Nx,1); HD := HIGH-REF(HIGH,1); LD := REF(LOW,1)-LOW; DMP:= NJT(IF(HD0 AND HDLD,HD,0),Nx,1); DMM:= NJT(IF(LD0 AND LDHD,LD,0),Nx,1); PDI:= DMP*100/ATR; MDI:= DMM*100/
ATR := NJT(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),Nx,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= NJT(IF(HD>0 AND HD>LD,HD,0),Nx,1);
DMM:= NJT(IF(LD>0 AND LD>HD,LD,0),Nx,1);
PDI:= DMP*100/ATR;
MDI:= DMM*100/ATR;
ADX: NJT(ABS(MDI-PDI)/(MDI+PDI)*100,Nx,1);
ADXR:=(ADX+REF(ADX,Nx))/2;
30;50;
NKOITRE(cross(ADX,30),ADX,30,10,0),Color00FFFF,LINETHICK5;
来势线:=EMA(CLOSE,7)-EMA(CLOSE,21),COLORYELLOW;
阻力线:=(zx + N*STD(CLOSE,M)),POINTDOT,LINETHICK2,colorgreen;
拉升力:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,47))*1.8*CLOSE;
拉升力A:=NJT(拉升力,9,1);
波峰波谷:=NJT(拉升力A,4,1),colorwhite;
拉升力B:=3*拉升力A-2*波峰波谷;
空方:=3*波峰波谷-1* 拉升力A;
做空:=IF(空方>拉升力B,拉升力B,空方),LINETHICK2,Color00FF00;
短线:=(CLOSE-ma(CLOSE,13))/ma(CLOSE,13)*40,LINETHICK0,COLORYELLOW;
中线:=(CLOSE-MA(CLOSE,4))/MA(CLOSE,4)*40,LINETHICK0,colorwhite;
上升趋势:=NJT(短线,3,1),LINETHICK0,Color0000FF;
下降趋势:=NJT(中线,3,1),colorstick,ColorFFFF00;
{上升趋势}
NKOITRE(上升趋势<ref(上升趋势,0.5)and 上升趋势>0,0,上升趋势,4,0),COLOR0000AA;
NKOITRE(上升趋势<ref(上升趋势,0.5)and 上升趋势>0,0,上升趋势,4,0),COLOR0000BB;
NKOITRE(上升趋势<ref(上升趋势,0.5)and 上升趋势>0,0,上升趋势,4,0),COLOR0000CC;
NKOITRE(上升趋势<ref(上升趋势,0.5)and 上升趋势>0,0,上升趋势,4,0),COLOR0000DD;
NKOITRE(上升趋势<ref(上升趋势,0.5)and 上升趋势>0,0,上升趋势,4,0),COLOR0000EE;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势>0,0,上升趋势,2,0),COLOR0000FF;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势>0,0,上升趋势,1,0),COLORRED;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势>0,0,上升趋势,4,0),COLOR0000AA;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势>0,0,上升趋势,4,0),COLOR0000BB;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势>0,0,上升趋势,4,0),COLOR0000CC;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势>0,0,上升趋势,4,0),COLOR0000DD;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势>0,0,上升趋势,4,0),COLOR0000EE;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势>0,0,上升趋势,2,0),COLOR0000FF;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势>0,0,上升趋势,1,0),COLORRED;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,4,0),COLOR0000FF;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,4,0),COLOR0033FF;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,4,0),COLOR0055FF;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,4,0),COLOR0077FF;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,4,0),COLOR0099FF;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,2,0),COLOR00BBFF;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,1,0),COLOR00DDFF;
NKOITRE(下降趋势<ref(下降趋势,1) and 下降趋势>0,0,下降趋势,1,0),COLOR00FFFF;
NKOITRE(上升趋势>ref(上升趋势,0)and 上升趋势<0,0,上升趋势,4,0),COLORFF0000;
NKOITRE(上升趋势>ref(上升趋势,0)and 上升趋势<0,0,上升趋势,4,0),COLORFF3300;
NKOITRE(上升趋势>ref(上升趋势,0)and 上升趋势<0,0,上升趋势,4,0),COLORFF5500;
NKOITRE(上升趋势>ref(上升趋势,0)and 上升趋势<0,0,上升趋势,4,0),COLORFF7700;
NKOITRE(上升趋势>ref(上升趋势,0)and 上升趋势<0,0,上升趋势,4,0),COLORFF9900;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势<0,0,上升趋势,2,0),COLORFFBB00;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势<0,0,上升趋势,1,0),COLORFFDD00;
NKOITRE(上升趋势>ref(上升趋势,1)and 上升趋势<0,0,上升趋势,1,0),COLORFFFF00;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,4,0),COLORFF0000;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,4,0),COLORFF3300;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,4,0),COLORFF5500;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,4,0),COLORFF7700;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,4,0),COLORFF9900;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,2,0),COLORFFBB00;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,1,0),COLORFFDD00;
NKOITRE(上升趋势<ref(上升趋势,1)and 上升趋势<0,0,上升趋势,1,0),COLORFFFF00;
NKOITRE(下降趋势>ref(下降趋势,1)and 下降趋势<0,0,下降趋势,4,0),COLOR998800;
NKOITRE(下降趋势>ref(下降趋势,1)and 下降趋势<0,0,下降趋势,4,0),COLORBBAA90;
NKOITRE(下降趋势>ref(下降趋势,1)and 下降趋势<0,0,下降趋势,4,0),COLORDDCC99;
NKOITRE(下降趋势>ref(下降趋势,1)and 下降趋势<0,0,下降趋势,1,0),COLORFFEEBB;
(以上就是“通达信测量趋势强度指标公式”的全部内容,部分文章整理自网络,不构成投资建议! 选股公式网专注于提供股票入门基础知识。投资有风险,入市需谨慎! )
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
推荐内容