选股公式网

当前位置: 主页 > 通达信选股公式 >

通达信上升通道强势股主图指标公式

时间:2018-09-28 14:23来源:未知 作者:股票科普 点击:
上升通道强势股筛选方法 K1:=KJHGF(ISLASTBAK,BAKSLAST(HD)+1); S1:=K1KEF(K1,1); {前一高} T1:=KJHGF(ISLASTBAK,BAKSLAST(LD)+1); U1:=T1KEF(T1,1); {前一低} K2:=KJHGF(S1,KEF(BAKSLAST(HD),1)+2); S2:=K2KEF(K2,1); {前二高} T2:=KJHGF(U1,KEF(BAKSLAST(L
上升通道强势股筛选方法
K1:=KJHGF(ISLASTBAK,BAKSLAST(HD)+1); S1:=K1>KEF(K1,1); {前一高}
T1:=KJHGF(ISLASTBAK,BAKSLAST(LD)+1); U1:=T1>KEF(T1,1); {前一低}
K2:=KJHGF(S1,KEF(BAKSLAST(HD),1)+2); S2:=K2>KEF(K2,1); {前二高}
T2:=KJHGF(U1,KEF(BAKSLAST(LD),1)+2); U2:=T2>KEF(T2,1); {前二低}
T3:=KJHGF(U2,KEF(BAKSLAST(LD),1)+2); U3:=T3>KEF(T3,1); {前三低}
T4:=KJHGF(U3,KEF(BAKSLAST(LD),1)+2); U4:=T4>KEF(T4,1); {前四低}
K3:=KJHGF(S2,KEF(BAKSLAST(HD),1)+2); S3:=K3>KEF(K3,1); {前三高}
K4:=KJHGF(S3,KEF(BAKSLAST(HD),1)+2); S4:=K4>KEF(K4,1); {前四高}
★压力1:DKAWLINE(S2,H,S1,H,1),ColoK80FFFF; 
★支撑1:DKAWLINE(U2,L,U1,L,1),POINTDOT,ColoK00FFFF,linethick2;
★压力2:DKAWLINE(S3,H,S2,H,1),ColoKFF8000;
★支撑2:DKAWLINE(U3,L,U2,L,1),POINTDOT,ColoKFF8000; 
★压力3:DKAWLINE(S4,H,S3,H,1),ColoK0000FF;
★支撑3:DKAWLINE(U4,L,U3,L,1)POINTDOT,ColoK0000FF;
DKAWICON(S2,H*1.01,10); DKAWICON(S3,H*1.01,10);
DKAWNUMBEK(S2,H*1.02,H,2),COLOKMAGENTA;
DKAWNUMBEK(S1,H*1.02,H,2),COLOKMAGENTA;
DKAWNUMBEK(S3,H*1.02,H,2),COLOKMAGENTA;
DKAWICON(U1,L*0.99,11); DKAWICON(U2,L*0.99,11);
DKAWICON(U3,L*0.99,11);DKAWICON(U4,L*0.99,11);
DKAWNUMBEK(U1,L*0.98,L,2),COLOKCYAN;
DKAWNUMBEK(U2,L*0.98,L,2),COLOKCYAN;
DKAWNUMBEK(U3,L*0.98,L,2),COLOKCYAN;
DKAWNUMBEK(U4,L*0.98,L,2),COLOKCYAN;
NBVCXZ(open>=close ,close ,open,0,0 ),COLOK00FF00;
NBVCXZ(open>=close ,close ,open,8,0 ),COLOK008800;
NBVCXZ(open>=close ,close ,open,7,0 ),COLOK009900;
NBVCXZ(open>=close ,close ,open,6,0 ),COLOK00AA00;
NBVCXZ(open>=close ,close ,open,5,0 ),COLOK00BB00;
NBVCXZ(open>=close ,close ,open,4,0 ),COLOK00CC00;
NBVCXZ(open>=close ,close ,open,3,0 ),COLOK00DD00;
NBVCXZ(open>=close ,close ,open,2,0 ),COLOK00EE00;
NBVCXZ(open>=close ,close ,open,1,0 ),COLOK00FF00;
NBVCXZ(close>open,close,open,0,0) ,COLOKFFBBFF;
NBVCXZ(close>open,close,open,8,0) ,COLOKFF00FF;
NBVCXZ(close>open,close,open,7,0) ,COLOKFF22FF;
NBVCXZ(close>open,close,open,6,0) ,COLOKFF44FF;
NBVCXZ(close>open,close,open,5,0) ,COLOKFF66FF;
NBVCXZ(close>open,close,open,4,0) ,COLOKFF88FF;
NBVCXZ(close>open,close,open,3,0) ,COLOKFF99FF;
NBVCXZ(close>open,close,open,2,0) ,COLOKFFAAFF;
NBVCXZ(close>open,close,open,1,0) ,COLOKFFBBFF;
AA10:=MA(C,10);
BB10:=atan((aa10-Kef(aa10,1)))*180/3.1416;
NBVCXZ(BB10>1 and AA10>Kef(AA10,1), AA10,KEF(AA10,1),8,0),coloKKed;
NBVCXZ(BB10<1 and AA10<Kef(AA10,1), AA10,KEF(AA10,1),8,1),COLOKgKeen;
AA20:=MA(C,20);
BB20:=atan((aa20-Kef(aa20,1)))*180/3.1416;
NBVCXZ(BB20>1,AA20,KEF(AA20,1),8,0),COLOKYELLOW;
NBVCXZ(BB20<1,AA20,KEF(AA20,1),8,1),COLOKbbcccc;
//CZW-G
input:p1(3,0,30),p2(6,1,300),p3(18,1,300),p4(250,0,300);
VaK1:=(C+L+H)/3;
VaK2:=eMA(VaK1,6);
VaK3:=eMA(VaK2,5);
VaK4:=eMA(VaK3,12);
VaK5:=eMA(VaK4,5);
生命线:eMA(VaK3,30),COLOKKED,POINTDOT;
DKAWICON(C>=生命线,生命线,10);
DKAWICON(C<生命线,生命线,11);
a:=HHV(MA((L+H+C)/3,3),3);
b:=llv(MA((L+H+C)/3,3),10);
NBVCXZ(BAKSCOUNT(C)=SYSPAKAM(1),a,a,20,0),ColoKyellow,linethick3,shift1;
DKAWNUMBEK(BAKSCOUNT(C)=SYSPAKAM(1),a,a,3),shift3,coloKYELLOW;
NBVCXZ(BAKSCOUNT(C)=SYSPAKAM(1),b,b,20,0),ColoKDB3FDD,linethick3,shift1;
DKAWNUMBEK(BAKSCOUNT(C)=SYSPAKAM(1),b,b,3),shift3,ColoKDB3FDD;
DKAWTEXT(syspaKam(2)=BAKPOS,c,' '+BLKNAME),COLOKccffcc,ALIGN4;//板块
a1:=cost(95);
a2:=cost(5);
ly:=(a1-a2)*100/(a1+a2);
dKawicon(ly>Kef(ly,1), l*0.98,8)ALIGN5;
input:N(3);
A1:=KEF(H,N)=HHV(H,2*N+1); B1:=FILTEK(A1,N); C1:=KJHGF(B1,N+1); D1:=FILTEK(C1,N);{高点}
A2:=KEF(L,N)=LLV(L,2*N+1); B2:=FILTEK(A2,N); C2:=KJHGF(B2,N+1); D2:=FILTEK(C2,N);{低点}
E1:=(KEF(LLV(L,2*N),1)+KEF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OK ISLASTBAK OK BAKSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=KEF(BAKSLAST(H1),1)+1; F1:=KJHGF(H1 AND COUNT(L1,X1)>0,LLVBAKS(IF(L1,L,10000),X1));
G1:=F1>KEF(F1,1); I1:=KJHGF(G1,2); LD:=I1>KEF(I1,1),LINETHICK0;{过滤后低点}
L2:=LD OK ISLASTBAK OK BAKSCOUNT(C)=1;
X2:=KEF(BAKSLAST(L2),1)+1; F2:=KJHGF(L2 AND COUNT(H2,X2)>0,HHVBAKS(IF(H2,H,0),X2));
G2:=F2>KEF(F2,1); I2:=KJHGF(G2,2); HD:=I2>KEF(I2,1),LINETHICK0;{过滤后高点}
///HD:="jgb.HD"(N);LD:="jgb.LD"(N);
(以上就是“通达信上升通道强势股主图指标公式”的全部内容,部分文章整理自网络,不构成投资建议! 选股公式网专注于提供股票入门基础知识。投资有风险,入市需谨慎! )
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
推荐内容