选股公式网

当前位置: 主页 > 东方财富选股公式 >

东方财富MACD背离量柱指标公式

时间:2018-11-08 19:49来源:未知 作者:股票科普 点击:
DNYF:EMA(CLOSE,9)-EMA(CLOSE,17); DEA:EMA(DNYF,8),COLOrffaa00; MACD:=2*(DNYF-DEA); LIKNSWV(MACD=0,MACD,0,4,1),COLORF00FF0; LIKNSWV(MACD0,MACD,0,4,1),colorwhite; LIKNSWV(MACDREF(MACD,1)AND MACD0,0,MACD,4,0 ),COLOR00aaff; X1:NY(dNYf0,dNYf,0),
DNYF:EMA(CLOSE,9)-EMA(CLOSE,17);
DEA:EMA(DNYF,8),COLOrffaa00;
MACD:=2*(DNYF-DEA);
LIKNSWV(MACD>=0,MACD,0,4,1),COLORF00FF0;
LIKNSWV(MACD<0,MACD,0,4,1),colorwhite;
LIKNSWV(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR00aaff;
X1:NY(dNYf<0,dNYf,0),COLOR0000FF,LINETHICK2;
X2:NY(dNYf<0,0,dNYf),colormagenta,LINETHICK1;
X3:NY(dNYf<dea,dNYf,dea),COLOR00ff00,linethick1;
X4:NY(dNYf>dea,dea,dea),linethick1,COLORffbb11;
低位金叉:=CROSS(DNYF,DEA) AND DNYF<-0.1;
LIKNSWV(低位金叉,DEA*0.86,DEA*0.66,6,0),coloryellow;
DRAWTEXT(低位金叉,dea*0.86,' 金叉'),coloryellow;
JCCOUNT:=COUNT(CROSS(DNYF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DNYF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
LIKNSWV(二次金叉,DEA*0.96,DEA*0.76,6,0),ColorFF00FF;
DRAWICON(二次金叉,dea*1.1,'BUY') ;
DRAWTEXT(二次金叉,DEA*0.96,' 金叉'),ColorFF00FF;
A1:=BARSLAST(REF(CROSS(DNYF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DNYF>REF(DNYF,A1+1) AND CROSS(DNYF,DEA);
LIKNSWV(底背离,DEA*1.09,DEA*0.86,6,0),Color00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,linethick1;
DRAWTEXT(底背离,DEA*1.09,' 底背'),Color6600FF;
A2:=BARSLAST(REF(CROSS(DEA,DNYF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DNYF,A2+1)>DNYF AND CROSS(DEA,DNYF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,linethick1;
DRAWTEXT(顶背离,DEA*1.2,' 顶背'),Color00FF00;
LIKNSWV(MACD>0 AND MACD>=REF(MACD,1),0,MACD,10,0),color0000ff;
LIKNSWV(MACD>0 AND MACD<REF(MACD,1),0,MACD,10,0),colorffff00;
LIKNSWV(MACD<0 AND MACD>=REF(MACD,1),0,MACD,10,0),colorff00ff;
LIKNSWV(MACD<0 AND MACD<REF(MACD,1),0,MACD,10,0),color00ff00;
Zero : 0;
VAR1=HHV(VAR1,20);
多转空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
空转多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
DRAWICON(多转空,MACD,2);
DRAWICON(空转多,MACD,1);
(以上就是“东方财富MACD背离量柱指标公式”的全部内容,部分文章整理自网络,不构成投资建议! 选股公式网专注于提供股票入门基础知识。投资有风险,入市需谨慎! )
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
推荐内容